Colombia - ACH - PSE - Decrease in Conversion Rates

Incident Report for D24

Resolved

This incident has been resolved.
Posted Nov 22, 2025 - 08:23 UTC

Monitoring

We are now seeing the conversion rates reaching the expected values. We will keep monitoring throughout ACH maintenance and inform you of further issues.
Posted Nov 22, 2025 - 07:39 UTC

Identified

We would like to inform you that ACH-PSE is undergoing internal maintenance. During this time, the PSE payment service may experience intermittent issues when creating and approving transactions
Posted Nov 22, 2025 - 06:21 UTC
This incident affected: Payment methods (Colombia - PSE).