Mexico - BBVA - Decrease in Conversion Rates
Incident Report for D24
Resolved
This incident has been resolved.
Posted Apr 16, 2024 - 17:46 UTC
Monitoring
We are now seeing the conversion rates reaching the expected values. We will keep monitoring and inform you of further issues.
Posted Apr 16, 2024 - 17:33 UTC
Investigating
We are currently investigating this issue.
Posted Apr 16, 2024 - 17:11 UTC
This incident affected: Payment methods (Mexico - BBVA Bancomer).