Mexico - Mercado Pago - Decrease in Conversion Rates

Incident Report for D24

Resolved

This incident has been resolved.
Posted Jun 07, 2025 - 10:17 UTC

Investigating

We are currently investigating this issue.
Posted Jun 02, 2025 - 13:49 UTC
This incident affected: Payment methods (Mexico - Mercado Pago).