AWS Incident Impacting Multiple Services

Incident Report for D24

Resolved

This Incident has been Resolved.
Posted Oct 21, 2025 - 01:53 UTC

Monitoring

We are now seeing numbers reaching the expected values.
Our team continues to monitor the situation closely and will provide updates as new information becomes available.
Posted Oct 20, 2025 - 23:21 UTC

Identified

AWS is currently recovering from a major incident in the US-EAST-1 region, which caused increased error rates, latency, and connectivity issues across multiple services.
AWS has applied several mitigations and is showing signs of recovery, but some services may still experience intermittent instability as systems return to normal.
Our team continues to monitor the situation closely and will provide updates as new information becomes available.
Posted Oct 20, 2025 - 15:13 UTC
This incident affected: External Providers (AWS health).