Colombia - ACH - PSE - Decrease in Conversion Rates

Incident Report for D24

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 06:30 UTC

Monitoring

We are now seeing the conversion rates reaching the expected values. We will keep monitoring and inform you of further issues.
Posted Feb 18, 2026 - 06:05 UTC

Identified

We would like to inform you that ACH-PSE is undergoing an internal maintenance. During this time, the PSE payment service may experience intermittent issues when creating and approving transactions
Posted Feb 18, 2026 - 05:23 UTC
This incident affected: Payment methods (Colombia - PSE).