Mexico - BBVA - Decrease in Conversion Rates

Incident Report for D24

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 14:40 UTC

Monitoring

We are now seeing the conversion rates reaching the expected values. We will keep monitoring and inform you of further issues.
Posted Mar 24, 2025 - 13:06 UTC

Identified

We would like to inform you that BBVA is presenting issues on their side, resulting in an intermittence that affects the BBVA Bancomer and SPEI payments. All D24 services are fully functional.
We are closely monitoring the situation and will update you on this incident as soon as we see any improvements.
Posted Mar 24, 2025 - 09:53 UTC

Investigating

We are currently investigating this issue.
Posted Mar 24, 2025 - 09:21 UTC
This incident affected: Payment methods (Mexico - BBVA Bancomer, Mexico - Spei).