Mexico - Spei - Decrease in Conversion Rates
Incident Report for D24
Resolved
This incident has been resolved.
Posted Apr 10, 2024 - 21:46 UTC
Monitoring
We are now seeing the conversion rates reaching the expected values. We will keep monitoring and inform you of further issues.
Posted Apr 10, 2024 - 21:29 UTC
Update
We are continuing to investigate this issue.
Posted Apr 10, 2024 - 19:15 UTC
Investigating
We are currently investigating this issue.
Posted Apr 10, 2024 - 18:38 UTC
Monitoring
We are now seeing the conversion rates reaching the expected values. We will keep monitoring and inform you of further issues.
Posted Apr 10, 2024 - 18:34 UTC
Investigating
We are currently investigating this issue.
Posted Apr 10, 2024 - 17:56 UTC
This incident affected: Payouts (Mexico) and Payment methods (Mexico - BBVA Bancomer, Mexico - Spei).