Mexico - Spei - Decrease in Conversion Rates
Incident Report for D24
Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 05:21 UTC
Monitoring
We are now seeing the conversion rates reaching the expected values. We will keep monitoring and inform you of further issues.
Posted Apr 26, 2024 - 03:38 UTC
Update
We are closely investigating the situation and will update on this incident as soon as we observe any improvements
Posted Apr 26, 2024 - 01:56 UTC
Investigating
We are currently investigating this issue.
Posted Apr 25, 2024 - 13:06 UTC
This incident affected: Payouts (Mexico) and Payment methods (Mexico - Spei).