AWS Incident Impacting Multiple Services

Incident Report for D24

Resolved

This incident has been resolved.
Posted May 08, 2026 - 01:52 UTC

Monitoring

We are now seeing numbers reaching the expected values. Our team continues to monitor the situation closely and will provide updates as new information becomes available.
Posted May 08, 2026 - 01:40 UTC

Identified

AWS is currently experiencing a major incident in the US-EAST-1 region, which is causing increased error rates, latency, and connectivity issues across multiple services.
Our team continues to monitor the situation closely and will provide updates as new information becomes available.
Posted May 08, 2026 - 01:22 UTC
This incident affected: External Providers (AWS health).