Mexico - Provider Issues
Incident Report for D24
Resolved
This incident has been resolved.
Posted Jul 21, 2024 - 21:32 UTC
Monitoring
We are now seeing the conversion rates reaching the expected. We will keep monitoring and inform you of further issues.
Posted Jul 21, 2024 - 20:35 UTC
Identified
The provider has been facing issues with their platform, causing a partial outage in the approvals for payout and a decrease in the conversion rate for SPEI and BBVA Bancomer. They are working on a fix and since any news becomes available we will inform you.
Posted Jul 21, 2024 - 19:21 UTC
This incident affected: Payouts (Mexico) and Payment methods (Mexico - BBVA Bancomer, Mexico - Spei).