Cash-in Processing Delay

Incident Report for D24

Resolved

This incident has been resolved.
Posted May 14, 2026 - 10:30 UTC

Investigating

Between 02:35 and 02:47 UTC, cash-in transactions experienced delays of up to 7 minutes to complete. All transactions were processed successfully.

The issue has been resolved as of 02:47 UTC. We are investigating the root cause and will share further details once available.
Posted May 14, 2026 - 02:58 UTC